MockupUI Reference Manual

Menu and toolbar

This section describes the actions available in the MockupUI's menu and toolbar.

Creating a new project

Select File > New Project or click the New Project tool button to create a new MockupUI project.

MockupUI - New project

MockupUI offers the possibility to work with several open projects at the same time, each project having its own window. You can switch between projects from your operating system task bar.

When MockupUI starts, a new project will be created by default allowing you to begin designing mockups immediately.

Opening an existing project

Click the Open Project item from the File menu or select an existing one from the Recent Projects. This will load the project file in memory and display its content in the page browser.

Open project

Saving a project

Click the Save button from the toolbar or Save Project from the File menu. This will create or update your project file. The first time you save a project you will need to select an output folder and specify a file name.

Save project

Saving a project file allows you to work on a project over several sessions. All the designs and customized widgets are saved into a .mui project file.

Note that MockupUI does not save the image files within the project, it only saves references to these files. If you need to move or make a copy of your project, you will also need to copy the media files and place them in the same folder structure as the original.

The File > Save As menu item allows you to save your project under a different name.

Closing a project

A project can be closed by selecting File > Close Project, Ctrl+W or clicking the Close tool button. You will be asked to save it before closing if you have made changes from the last time you saved it. Closing a project will remove it from memory and will create a new empty project.

MockupUI - Close project

Cutting, Copying, Pasting

MockupUI provides a number of Clipboard operations. You can copy, cut and paste a widget that you selected in the design area or designs from the design browser. It is also possible to copy and paste effect parameter values inside the parameters panel.

MockupUI - Clipboard

Ctrl+X (Cut): Remove the selected item and put it onto the clipboard.

Ctrl+C (Copy): Put a copy of the selected item onto the clipboard.

Ctrl+V (Paste): Paste the last item found on the clipboard to the current page.

Ctrl+D (Duplicate): Create a copy of the selected item and insert it at the current position.

Ctrl+L (Clone): Create a clone of the current design.

Undo and redo

The Undo command discards the last changes you have made in one of the editors. The Redo command discards the results of the last Undo command.

MockupUI - Undo / redo

To undo an action select Edit > Undo, press Ctrl+Z or click the Undo tool button.

To redo an action select Edit > Redo, press Ctrl+Shift+Z or click the Redo tool button.

Creating designs

Create a new design by selecting the File > New Design from the menu or clicking on the New design tool button.

MockupUI - Undo / redo

Exporting

MockupUI can export the designs as individual image files or as a PDF document. Refer to Exporting to learn more.

MockupUI - Exporting

Visual style

Change the visual style of the widgets by selecting a native or wireframe look from the list.

MockupUI - Visual styles

Exiting MockupUI

Select File > Quit or Ctrl+Q to quit the application. If you have one or more unsaved projects open, you will be asked to save them before exiting.